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L-Systems 1

These L-system activities are designed to help you create designs like the ones shown below.

      

Pretend that on the computer screen is a turtle facing towards the right. If you give the turtle the command ‘F’,

the turtle will crawl forward one unit and will leave a mark on the screen as it crawls. If you give the turtle the

command ‘G’, the turtle will crawl forward one unit, but will not leave a mark as it crawls.

So if the turtle sees the commands ‘FGFF’, it will crawl forward  one unit while leaving a mark. Then it will

crawl forward one unit without leaving a mark. Then it will crawl forward two units while leaving a mark. So

the resulting drawing will look like this:  

Normally, to make a drawing that will be interesting, we want the turtle to be able to turn to the left or the right.

The command ‘+’ tells the turtle turn to its left (i.e., counterclockwise). The command ‘-’ tells the turtle turn to

its  right  (i.e.,  clockwise).  Before  telling  the  turtle  ‘+’  or  ‘-’,  we will  tell  the  turtle  how far  to  turn.  The

instruction ‘Angle 4’ tells the turtle to turn 
1

4  of a circle (i.e., 90°) whenever it is told ‘+’ or ‘-’. The instruction

‘Angle 6’ tells the turtle to turn 60° whenever we command it to turn (since 360°÷6 = 60°). Suppose the turtle

is told ‘Angle 12’ and then is commanded ‘F+F+F----F+F’. It will 1st crawl forward one unit. Then it will turn

counterclockwise 30° (since 360°÷12 = 30°). Then it will crawl forward a unit (so the drawing now looks like

this:  ). Then it will turn left 30° again and crawl forward (now the drawing looks like this:  ). Then it

will turn right (i.e., clockwise) 4 times (for a total of 120°). Then it will crawl forward once (the drawing now

looks like this:  . Then it will turn counterclockwise 30° and crawl forward to finish the drawing.

Try to understand how the commands ‘F+F+F----F+F’ produce this drawing:  . To learn how to tell the

computer to make designs, start the program Arcnel. Click Edit on the menu bar and then click New L-system.

This displays the L-system window. After reading this paragraph, edit the text in the L-system window so that it

contains the commands that follow this paragraph. The first line of a formula contains the name of the formula

and a ‘{’ (left brace). The brace tells the computer that the formula is now beginning. The next line tells the

turtle how far to turn when it receives a ‘+’ or ‘-’ command. You do not yet need to understand the significance

of the word ‘Axiom’. Just make sure it is in the L-system. The word ‘Axiom’ is followed by the commands for

the turtle. The formula ends with a ‘}’ (right brace). To quickly change the name of the L-system, double-click

‘New’ in the  L-system window and type ‘Sample1 ’ (Be sure to type the space at the end.  Do not type the quotes that

surround what is to be typed). Edit the text in the L-system window until it contains these commands:

Sample1 {

  Angle 12

  Axiom F+F+F----F+F

}

Be sure that ‘Sample1’ has no space in it. Put a 

space after ‘Sample1’ and before the ‘{’.

Save this paper for future reference.



To have the computer process the Sample1 L-system, click Edit on the menu bar and then click Process Shown

Text. The Arcnel window should then draw this design: 

To save the Sample1 L-system, click File on the menu and then click Save L-system To File. Then type your

initials followed by “.AL”. For example, if you initials are PQR, then type PQR.AL for the file name. Then click

the Save button.

Now select  New L-system in the  Edit menu and edit the text in the  L-system window that appears so that it

contains the commands that follow this paragraph. When you come to a ‘;’ (semicolon), you do not need to

type the rest of that line. For each line, you do need to type all of the text that is before a semicolon. If a line

does not contain a semicolon, then type everything on that line.

Pentagon {        ; If the computer sees a semicolon, it ignores the rest of that line.

  Angle 5         ; 360/5 = 72. All text before a semicolon must be typed.

  Axiom F+F+F+F+F ; '+' = 'turn counterclockwise one-fifth of a circle'

}

To have the computer process the Pentagon L-system, select Process Shown Text in the Edit menu. The Arcnel

window should then draw a pentagon. To save the Pentagon L-system, select Save L-system To File in the File

menu. Then select the “.AL” file you saved above and click the Save button.

Now select  New L-system in the  Edit menu and edit the text in the  L-system window that appears so that it

contains the following commands:

Star { ; If text after a ';' isn’t typed, then the ';' doesn’t need to be typed either.

  Angle 10 ; 360/10 = 36. '-' = 'turn clockwise one-tenth of a circle'

  Axiom F----F----F----F----F

}

Select Process Shown Text in the Edit menu. The Arcnel window should then draw a 5-pointed star. Using the

procedure taught above, now save the Star L-system to your “.AL” file.

To watch how the turtle draws the star, select Debug in the Edit menu. In the Debug window, click Next on the

menu bar to have the turtle move one unit. Answer the following questions (you may write on this paper):

1) Click Next again. The leftmost triangle in the Debug window should have rotated. Point the mouse at that

triangle. The computer should display an angle measure. What is that angle measure?

2) Click  Next again.  Point the mouse at the leftmost  triangle in the  Debug window. The computer should

display an angle measure. What is that angle measure?

3) Click Next. Write the new angle measure.

4) Click Next. Write the new angle measure.

5) Click Next. The turtle should crawl forward one unit. Now click Next four times to make the turtle turn four

times. Write the new angle measure.

6) Click Auto. Watch the turtle. Once the turtle is done moving, what is the angle measure?

7) Click Next. This exits Debug mode. Select Open in the File menu. Select the “.AL” file you saved and click

the Open button. Click Pentagon in the list of L-systems. Click OK. An Order window should appear. A

later activity teaches about the “Order” concept. For now, just click OK in the Order window. This should

draw a pentagon. Select  Debug in the  Edit menu. A window on the screen should show the commands

‘F+F+F+F+F’. The title bar of that window should show the text “Length:” followed by a number. Write that

number.

8) Click Next in the Debug window. The first ‘+’ in the Length window should be selected. This means that ‘+’

is the next command. Click Next to perform that command. Write the new angle measure.

9) Click Auto. Write the angle measure once the turtle stops moving. You may now exit from Arcnel.

Do not discard this activity until after completing the rest of the activities.



Name ____________

L-Systems 2

Start the program Arcnel. Click Edit on the menu bar and then click New L-system. Edit the text in the L-system

window until it contains these commands:

KochCurve2 { ; Remember to always type all text that precedes a semicolon.

  Angle 6    ; 360/6=60. '-' = 'turn clockwise one-sixth of a circle'

  Axiom FGF  ; Text after a semicolon doesn't need to be typed.

  F=F+F--F+F ; The lines after the axiom line contain substitution rules.

  G=GGG      ; Don’t forget there are braces at the beginning and the end!

}

To have the computer process the KochCurve2 L-system, select Process Shown Text in the Edit menu. Save the

L-system as instructed in the first activity. Then select  L-system Order in the  Edit menu. In the window that

pops up, type the digit 0 (zero). Click  OK. Since the formula contains the command ‘Axiom FGF’, the turtle

draws a segment. Then it moves forward without leaving a mark. Then it draws another segment.

Now select  L-system Order in the  Edit menu. In the window that pops up, type the digit 1 (one). Click  OK.

Since  the  order  is  1,  the  computer  uses  the  substitution  rules  ‘F=F+F--F+F’  and  ‘G=GGG’  to  change  the

commands for the turtle. The substitution rule ‘F=F+F--F+F’ tells the computer to replace each ‘F’ in the axiom

with ‘F+F--F+F’. Likewise, ‘G=GGG’ tells the computer to replace the ‘G’ in the axiom with the string ‘GGG’. So

the computer replaces the original command string ‘FGF’ with the command string ‘F+F--F+FGGGF+F--F+F’.

The turtle uses this command string to draw the diagram. The computer automatically resizes the diagram so

that it fits on the screen. To watch how the turtle draws this design, select Debug in the Edit menu.

1) A window on the screen should show the commands ‘F+F--F+FGGGF+F--F+F’. The title bar of that window

should show the text “Length:” followed by a number. Write that number.

2) Click Next in the Debug window. Write the symbol that is selected in the Length window.

3) Click Next in the Debug window. Point the mouse at the leftmost triangle in the Debug window. What is the

angle measure?

Click Exit in the Debug window. If the order were ‘2’, the computer would perform the substitutions a second

time. The text that results at each step is shown in the following diagram. Each time, the computer replaces each

‘F’ with ‘F+F--F+F’ and replaces each ‘G’ with ‘GGG’.

Order 0 FGF

Order 1 F+F--F+FGGGF+F--F+F

Order 2 F+F--F+F+F+F--F+F--F+F--F+F+F+F--F+FGGGGGGGGGF+F--F+F+F+F--F+F--F+F--F+F+F+F--F+F

In this  example,  replacing ‘F’ with ‘F=F+F--F+F’ is equivalent to replacing each straight segment with the

shape . Change the order to 2 and see the substitution occur. Then change the order to 3 and see the

substitution occur again.

Click Edit on the menu bar and then click New L-system. Edit the text in the L-system window until it contains

these commands:

TriSpiral {

  Angle 3 ; 360/3 = 120. '+' = 'turn counterclockwise one-third of a circle'

  Axiom FYX ; As the turtle crawls, it ignores symbols it doesn't understand.

  Y=FY      ; When the turtle sees a Y, the turtle ignores it.

  X=+FYX

}

This formula contains symbols ‘X’ and ‘Y’. The turtle does not understand these symbols, so it ignores them.

But as the computer computes orders 1, 2, 3, etc., it follows the substitution rules ‘Y=FY’ and ‘X=+FYX’.

Do not discard this activity until after completing the rest of the activities.



Select  Process  Shown Text in  the

Edit menu.  Save  the  L-system.

Select  L-system Order in the  Edit

menu.  Change the order  to  0 and

click  OK.  Also try orders 1, 2, 3,

and 14. Select  Curve Width in the

Edit menu.  Type  the  digit  3  and

click OK.

Order Commands The part the turtle understands

0 FYX F

1 FFY+FYX FF+F

2 FFFY+FFY+FYX FFF+FF+F

Sometimes, to increase understanding of an L-system, it can help to have the turtle color the segments it draws.

Edit the text in the L-system window until it contains these commands:

TriSpiralColor { ; In the default color palette, color 15 is white.

  Angle 3

  Axiom C15FYX ; 'C15' tells the turtle to chose color 15.

  Y=>1FY       ; '>1' tells the turtle to decrease the color number by 1.

  X=+C15FYX    ; After each turn, chose color 15 again.

}

Select Process Shown Text in the Edit menu. Save the L-system. Try orders 1, 2, 3, and 4 to see how the turtle

colors different segments. Then try order 14. Notice how the first segment at the bottom-left is white (color 15).

The next segment is color 14. The next segment is color 13, etc. Then when the turtle turns 120°, it chooses

color 15 (white) again. To see the color palette, select Show Editable Color Map in the Color menu.

4) Point  the  mouse  at  the  white  square  in  the  color  palette.  The  computer  should  show  three lines  of

information. The first line shows that the color number is 15. Write the entire second line of information.

5) The second line of information shows the red, green, and blue values for the color. Move the mouse around

until you find color # 14. What are the red, green, and blue values for color 14?

Change the order to 3. For each one of the following three L-systems, first edit the L-system window so that it 

contains the L-system. Then select Process Shown Text in the Edit menu. Then save the L-system.

Snow { 

  Angle 6

  Axiom F+F+F+F+F+F

  F=F+FF+F--F--F+FF+F

}

SnowColor {

  Angle 6 ; '<2' --> increase color # by 2

  Axiom C2F+<2F+<1F+<2F+<4F+<2F

  F=F+FF+F--F--F+FF+F

}

SnowColor2 {

  Angle 6 ; '>2' --> decrease color # by 2

  Axiom F+F+F+F+F+F

  F=C13F+>2F>2F+>2F-->1F-->1F+>1F>1F+>1F

}

6) Select Open in the File menu. Select the “.AL” file you saved. Choose Snow in the L-system list and click

OK. Type 0 for the order and click OK. Name the shape produced.

7) Change the order to 1. Choose  Show Command String Text in the  Edit menu. The title bar of the  Length

window shows the length of the command string text. What is that length?

8) Select Choose L-system in the File menu. Choose SnowColor2 in the L-system list and click OK. Make sure

the order  is  1  and click  OK.  Select  Show Command String Text in  the  Edit menu.  What  is  the length

displayed in the title bar of the Length window?

9) Select Choose L-system in the File menu. Choose SnowColor in the L-system list and click OK. Make sure

the order is 1 and click OK. Select Debug in the Edit menu. What is the length displayed in the title bar of

the Length window?

10) Click Next in the Debug window. Remember the new color of the turtle. Now continue to click Next until

the turtle turns a different color. What is the measure of the angle for the turtle?

11) Click  Exit in the  Debug window. Change the order to 4. Choose  Show Command String Text in the  Edit

menu. A window should pop up. Don’t click any buttons. According to the window that pops up, how long

is the command string?

12) Click  No. Change the order to 3. Choose  Show Command String Text in the  Edit menu. How long is the

command string?

Substitution

Rules

Y=FY

X=+FYX

IMPORTANT NOTICE

If you need to change an L-system after 

saving it, open the “.AL” file in Notepad 

and edit that file and then save it. Then 

select Open  in the File  menu in Arcnel 

to reopen the changed “.AL” file.

The Snow design should look similar to the top-left design on the “L-Systems 1” activity. If you saved a flawed L-system, see the IMPORTANT NOTICE above.



Name ____________

L-Systems 3

Start Arcnel. Select New L-system in the Edit menu. For each of the following three L-systems, type the entire

L-system in the L-system window and then process the text and then save the L-system.

KochCurve3 {

  Angle 6

  Axiom F!F!F

  F=F+F--F+F
}

KochCurve3Color {

  Angle 6

  Axiom C5FC7!F!C11F 

  F=F+F--F+F
}

Zigzag {

  Angle 3

  Axiom F

  F=F!-F
}

The command ‘!’ tells the turtle to reverse the meanings of ‘+’ and ‘-’. In the axiom ‘F!F!F’, the command ‘!’

has no effect (since there are no ‘+’ or ‘-’ commands). But after the computer substitutes ‘F+F--F+F’ for ‘F’,

the command ‘!’ does have an effect. After applying the substitution rule ‘F=F+F--F+F’ to the axiom ‘F!F!F’,

the command string is ‘F+F--F+F!F+F--F+F!F+F--F+F’. Normally,  ‘+’ means ‘turn counterclockwise’ and

‘-’ means ‘turn clockwise’. After the turtle sees the first ‘!’, then ‘+’ means ‘turn clockwise’ and ‘-’ means

‘turn counterclockwise’. When the turtle sees the next ‘!’, it again reverses the meanings of ‘+’ and ‘-’. So now

they are back to their original meanings.

Open the file to which you saved the above three formulas and choose KochCurve3 and click OK. Type the digit

1 for the order and click OK. Then select Debug in the Edit menu. Notice that an ‘N’ is displayed in the Debug

window. This means that ‘+’ and ‘-’ have their normal meaning. Click Next in the Debug window until the first

‘!’ is selected in the Length window. The Debug window should still show an ‘N’.

1) Click Next one more time. Write the letter that is now displayed instead of the ‘N’.

2) Click Next two more times. What is the angle measure for the turtle?

3) Click  Next in the  Debug window until the second ‘!’ is selected in the  Length window. Then click  Next

three more times. What is the angle measure for the turtle?

4) Click Exit. Select Choose L-system in the File menu. Choose KochCurve3Color, click OK, type the digit 2

for the order, and click OK. Select  Debug in the Edit menu. Observe the ‘N’ in the Debug window. Click

Auto in the Debug window and watch both the ‘N’ and the turtle. What is the color of the design when the

meanings of ‘+’ and ‘-’ are reversed?

5) Click  Exit. Select  Choose L-system in the  File menu. Choose  Zigzag, click  OK, type the digit 4 for the

order, and click OK. Select Debug in the Edit menu. Click Auto. When the turtle is finished moving, what is

the meaning of ‘-’? (Use words in the answer. Read the top paragraphs on this page if you have questions.)

Click Exit. Enter the following L-system, process it, and save it.

OctSpiralColor {

  Angle 8

  Axiom C16F

  F=F<1+@.99F ;'@' is the 'at' symbol which is found on the key for '2' on many keyboards

}

The command ‘@.99’ tells the turtle to crawl 99

100  as far as it used to crawl when it saw ‘F’ or ‘G’. For order 2

(i.e., after 2 substitutions), the command string is ‘C16F<1+@.99F<1+@.99F<1+@.99F’. For the 1st ‘F’, the turtle

crawls the normal distance. For the 2nd ‘F’, the turtle crawls 0.99 of the original distance. For the 3rd ‘F’, the

turtle crawls 0.99 of that new distance which means that it crawls 0.9801 of the original distance.

6) Do order 8 of OctSpiralColor. Select Spectrum Map in the Color menu. Select Debug in the Edit menu.

Observe the number 1 displayed in the “Length” column in the Debug window. Click Next until that number

changes. Write the new number.
 

Hint: Instead of clicking Next in the Debug window, you may press N on the keyboard if that window is

active. Also, you may press A instead of clicking Auto, and you may press  instead of clicking Exit.

IMPORTANT NOTICE

To delete an L-system after saving it, open the “.AL” file in 

Notepad  and delete the entire L-system (including the name 

and both braces). Then save the file. Then select Open in the 

File menu in Arcnel to reopen the changed “.AL” file.



7) Click Next until the number changes again. Write the new number.

8) Click Next until the number changes again. Write the new number.

Click Exit. Change the order to 3. Select Arcnel Map (Default) in the Color menu. Select New L-system in the

Edit menu. For  each of the following three L-systems, type the L-system in the  L-system window and then

process the text and then save the L-system. The ‘|’ symbol may look like ‘¦’ on the keyboard.

KochAlt2 {

  Angle 6

  Axiom F|F

  F=F+F--F+F

}

KochAlt6 {

  Angle 6

  Axiom F|FF|F+F|FF|F+F|FF|F

  F=F+F--F+F

}

KochAlt6Color {

  Angle 6

  Axiom C2F|F<2F|F+<1F|F<2F|F+<2F|F<2F|F

  F=F+F--F+F

}

If the ‘Angle’ command is an even number, then the ‘|’ command tells the turtle to turn 180°. So in KochAlt2,

the axiom ‘F|F’ is equivalent to ‘F+++F’. At order 0, ‘F|F’ causes the turtle to crawl forward, then turn around

and crawl back the way it came. So at order 0, the extra ‘F’ is not visible. At order 1 (after ‘F+F—F+F’ is

substituted for each ‘F’ in ‘F|F’), the command will be ‘F+F--F+F|F+F--F+F’.

9) Open the file to which you saved the above 3 formulas (Be sure to select Open instead of Choose L-system in the File

menu). Select KochAlt2 and let the order be 1. How many line segments are visible in the design?

10) Change the order to 2. The design should have 3 polygonal  regions.  How many sides does the central

polygon have?

11) Change the order to 3. How many polygonal regions are in the design?

12) Select Choose L-system in the File menu. Choose KochAlt6 and let the order be 1. Select Debug in the Edit

menu. Click Auto. When the turtle is finished moving, what is its angle measure?

13) Click Exit. Change the order to 5. Select Show Command String Text in the Edit menu. What is the length of

the text?

14) Select Choose L-system in the File menu. Choose KochAlt6Color and let the order be 2. Select Debug in the

Edit menu. Click Next until the turtle is at the rightmost point in the design. Click Next one more time. The

turtle should have changed its direction. By how many degrees did it change its direction?

15) Keep clicking Next until the turtle changes its color. What is its new color?

16) Keep clicking Next until the turtle changes its color again. What is its new color? (Make sure that the answers to

#15 and #16 are different. If they are the same, you probably need to change the answer for #15)

17) Click  Exit.  Press   on  the  keyboard.  The  Arcnel  Help window  should  appear.  According  to  the

information in it, who introduced L-systems?

IMPORTANT NOTICE

To temporarily “delete” an L-system after saving it, open the “.AL” file in Notepad and type a semicolon at the beginning of each line of the L-system (including the 

name and the ending brace). Then save the file. This causes Arcnel to ignore those lines since a semicolon indicates the beginning of a comment. Those lines have 

been “commented out.”
Do not discard this activity until after completing the rest of the activities.

HexagonalWalk {

  Angle 6

  Axiom Y

  Y=YF+X+XF+XF+XF+XF+XF

  X=XF

}

Both designs to the left were made using 

order 8 of HexagonalWalk. The first one 

was made using a width of 7. For the 

other, the width was changed to 17, and 

Dot Mode was selected in the Edit menu.



Name ____________

L-systems 4

Start Arcnel. Select New L-system in the Edit menu. For each of the following three L-systems, type the entire

L-system in the L-system window and then process the text and then save the L-system.

DoubleSpiral {

  Angle 40

  Axiom ----[F]|F

  F=F+@.98F

}

FlakeV {

  Angle 5

  Axiom F+F+F+F+F

  F=F+F[+F]--F+F

}

FlakeVColor {

  Angle 5

  Axiom C2F+<2F+<1F+<2F+<4F

  F=F+F[+F]--F+F

}

The ‘[’ command tells the turtle to remember its current condition (which includes its position, direction, color,

length of crawl, and meaning of ‘+’ and ‘-’). Then when the turtle is given the ‘]’ command, it goes back

(without leaving any marks) to the condition it had been in when it was given the ‘[’ command. 

1) Open the file to which you saved the above formulas. Choose DoubleSpiral and let the order be 5. Choose

Debug in the Edit menu. Click Next until the ‘[’ is selected in the Length window. Then click Next again.

The  Debug window should now show two lines of information. Look at the two leftmost triangles in the

“Angle” column. What is the angle of the top triangle?

2) What is the angle of the bottom triangle?

3) Click Next until the ‘]’ is selected in the Length window. Now what is the angle of the top triangle?

4) What is the angle of the bottom triangle?

5) The “Length” column in the  Debug window shows the crawl length for the turtle. Write both the current

crawl  length  (top  line)  and  the  remembered  crawl  length  (bottom line)  with  as  much  precision  as  is

displayed in the Debug window.

6) While watching the turtle, click Next. The remembered conditions have now become the current conditions.

Click Next again. What is the current angle measure for the turtle?

7) Click Next two more times. By how many degrees did the angle measure change?

8) Click  Exit.  Select  Choose  L-system in  the  File menu.  Choose  FlakeV with  an order  of  1.  How many

pentagons are in the design?

9) Change the order to 5. Select  Show Command String Text in the  Edit menu. A window should pop up.

Carefully read it, but don’t click any buttons. According to that window, what is the length of the command

string?

10) Click  No.  Select  Choose L-system in the  File menu.  Choose  FlakeVColor with an order of 2. Choose

Debug in the Edit menu. Click Next until the first ‘[’ is selected in the Length window. Then click Next until

the first ‘]’ is selected. Then click  Next until the 2nd ‘[’ is selected. Then click  Next until the 2nd ‘]’ is

selected. Then click Next until the 3rd ‘[’ is selected. Then click Next until the 4th ‘[’ is selected. Click Next

three more times. The Debug window should show 3 lines of information. The left triangle in the 1 st line

shows the current angle of the turtle. The left triangle in the 2nd line shows the most recently remembered

angle. The left triangle in the 3rd line shows an angle that had been remembered earlier. Write all three angle

measures, starting with the current angle.

11) The Arcnel window shows two small circles drawn on the design. The one circle is larger than the other.

The  smaller  circle  shows  the  most  recently  remembered  location.  The  larger  circle  shows  an  earlier

remembered location. Carefully watch the larger circle as you click Next. What happens to that circle?

12) Click Next until the turtle turns green. What is its angle measure?

13) Click Exit. Change the order to 5. Observe how the colors are distributed around the design. Studying colors

may increase understanding regarding how the turtle crawls. Press . Find the “Push and Pop” section in

Arcnel Help. According to the information in that section, what is the ‘]’ command called?
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L-Systems 5

Start Arcnel. Select New L-system in the Edit menu. For each of the following two L-systems, type the L-system

in the L-system window and then process the text and then save the L-system.

KochSnow {

  Angle 12

  Axiom +F----F----F

  F=F++F----F++F

}

KochSnowBuild {

  Angle 12

  Axiom +FY----FY----FY

  F=    ;This is not a mistake

  X=FY

  Y=FX[F]++FX----FX++FX

}

The Koch snowflake is named after Helge von Koch. KochSnow can help you visualize the design.

1) Open the file to which you saved the above formulas. Choose KochSnow and let the order be 0. How many

line segments are in the design?

2) Change the order to 1. How many line segments are in the design?

3) Change the order to 2. How many line segments are in the design?

4) Change the order to 5. This should give you some idea of how the Koch snowflake would look. An infinite

order would be needed to produce the actual Koch snowflake. Select Show Command String Text in the Edit

menu. What is the length of that text?

5) Select  Choose L-system in the  File menu. Choose  KochSnowBuild and let the order be 0. This L-system

contains the substitution rule ‘F=’ (with nothing after ‘=’). This rule will replace ‘F’ with nothing (i.e., it will

delete each ‘F’). This L-system shows one way of visualizing the construction of the Koch snowflake. What

special type of triangle is displayed when the order is 0?

6) Change the order to 1. This places an equilateral triangle on the middle third of each side of the original

triangle. Now change the order to 2. This should erase the boundaries between the original triangle and the

little triangles. Now change the order to 3. How many little triangles does this add to the design?

7) Change the order to 4. This should erase the boundaries between the main design and the little triangles.

Change the order to 5. Select Debug in the Edit menu. Click Next until the first ‘]’ is selected in the Length

window. Write both the current angle measure for the turtle and the remembered angle measure.

8) Click Next three times. What is the current angle measure?

Click Exit. Select New L-system in the Edit menu. For each of the following two L-systems, type the L-system

in the L-system window and then process the text and then save the L-system.

QBlock2 {

  Angle 8

  Axiom F++F++F++F

  F=F[++F]G[@Q8+F]G++G|F++F

  G=GGGG ;4 G’s

}

Quilt2 {

  Angle 8

  Axiom F++F++F++F

  F=F[++F--F]@I2G@Q2+F++F++F++F@IQ2+G@2[++!F]F

  G=GGG ;3 G’s

}

9) In QBlock2, the command ‘@Q8’ multiplies the turtle’s crawl length by the square root of 8. In Quilt2, the

command ‘@I2’ multiples the crawl length by the inverse of 2 (i.e., 1

2 ). The command ‘@IQ2’ multiplies the

crawl length by the inverse of the square root of 2. Do order 1 of Quilt2. How many squares are tilted?

10) The  commands  for  drawing  tilted  squares  are  found  between  the  commands  ‘@Q2’  and  ‘@IQ2’.  The

command ‘@IQ2’ restores the crawl length to what it had been before the ‘@Q2’ command. Select Debug in

the Edit menu. Click Next until the first ‘@I2’ is selected. What is the current crawl length?



11) Click Next once. What is the new crawl length?

12) Click Next twice. Write the new crawl length rounded to three decimal places.

13) Click Next until the first ‘@2’ is selected. What is the current crawl length?

14) Click Next once. What is the new crawl length?

15) Click Exit. Change the order to 5. Select Show Command String Text in the Edit menu. A window should

pop up. Do not click any buttons. According to the window that pops up, what is the length of the command

string?

16) Click  No. Open the file to which you saved the formulas. Choose  QBlock2 and let the order be 1. Select

Debug in  the  Edit menu.  The  command  for  drawing  one  side  of  the  large  tilted  square  is  the  ‘F’  in

‘[@Q8+F]’. Notice that at the ‘]’ command, the turtle returns to the condition in which it had been when it

received the ‘[’ command (including the size of the crawl). So the command ‘@IQ8’ was not needed to

restore the crawl length to its original size. How many squares are in the design?

17) Click Next until the first ‘@Q8’ is selected. What is the crawl length?

18) Click Next once. Write the current crawl length rounded to 3 decimal places.

19) Click Next twice. What is the current angle measure?

20) Click Next once. Write both the current angle and crawl length.

21) Click Exit. Change the order to 2. How many tilted squares are in the design?

22) Study the central square in the order 2 diagram. Then study the central squares for orders 3, 4, and 5. How

does the central square in an odd order compare to the central square in an even order?

The above designs are orders 0 through 4 of the L-system shown below.

Flake6Fill {

  Angle 6

  Axiom F+KF+KF+KF+KF+KF+K

  K=@I3F+KF+KF+[|K]KF+KF+KF+K@3

  F=G

}
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Start Arcnel. Select New L-system in the Edit menu. For each of the following two L-systems, type the L-system in

the L-system window and then process the text and then save the L-system.

FlakeIXb {

  Angle 9

  Axiom F+F+F+F+F+F+F+F+F

  F=F+F+F[+F+F+F]|F+F+F

;For Angle 9, '|'='+++++' for default meaning of '+'

}

MultiSpiral6G {

  Angle 40

  Axiom ----[FX]|FX

  X=[@.35Y][|@.35Y]+@.98F+@.98FX

  Y=++@.964FY

}

1) If the # in the command ‘Angle #’ is even, then ‘|’ tells the turtle to turn 180°. If the # is odd, then the turtle

will turn counterclockwise 180° and will keep turning until it reaches a multiple of 360° ÷ #. For ‘Angle 9’,

360°  ÷  9 = 40°. Since 4(40°) = 160° and 5(40°) = 200°, ‘|’ tells the turtle to turn counterclockwise 200°

(equivalent to turning clockwise 160°). So when ‘+’ and ‘-’ have their normal meanings, the ‘|’ is equivalent

to  ‘+++++’  which  is  equivalent  to  ‘----’.  Open the  file  to  which you  saved the  above formulas.  Choose

FlakeIXb and let the order be 1. Select Debug in the Edit menu. Click Next until the first ‘|’ is selected in the

Length window. What is the current angle measure for the turtle?

2) Click Next once. What is the current angle measure for the turtle?

3) Click Next until the next ‘|’ is selected in the Length window. What is the current angle measure for the turtle?

4) Click Next once. By how many degrees did the angle measure change?

5) Click Exit. MultiSpiral6G was derived from the DoubleSpiral formula of a previous activity. Order 8 works

well for  DoubleSpiral, but  MultiSpiral6G needs a much higher order. Select  Choose L-system in the  File

menu.  Choose  MultiSpiral6G with an order of 88. Select  Show Command String Text in the  Edit menu.

According to the window that pops up, what is the length of the command string?

6) Click No. Change the order to 3. Select Debug in the Edit menu. Click Next until the first ‘]’ is selected in the

Length window. What is the current angle measure for the turtle?

7) Click Next once. What is the current angle measure for the turtle?

8) Click Next until the next ‘]’ is selected in the Length window. What is the current angle measure for the turtle?

9) Click Exit. Open “Arcnel.AL” (If it doesn’t exist, click Cancel to close the Open dialog box. Select Write Arcnel.AL in the File

menu. Click the Save button. Then open “Arcnel.AL”). Choose FlakeX and let the order be 4. Then set the order to 1. The

design has 10 congruent regular polygons joined together. Write the name for those polygons.

10) Open “Fractint.L” (If it doesn’t exist, select Write Fractint.L in the File menu and click the Save button. Then open “Fractint.L”).

Choose Bush and let the order be 4. Select Show L-system Text in the Edit menu. Write the axiom (If you don't

know what the axiom is, press  and read Arcnel Help until you understand).

11) Select Choose L-system in the File menu. Choose Curve4 and let the order be 6. Also try orders 7, 8, and 9.

Concerning the overall design, how do the odd and even orders differ from each other?

12) Now choose Fass1 and let the order be 4. Then choose Peano2 and let the order be 4. Select Show L-system

Text in the Edit menu. Write the axiom.

13) Now choose Penrose4 and let the order be 4. Select Show L-system Text in the Edit menu. Write the axiom.

14) Now choose Island1 and let the order be 2. The design consists of three sizes of islands. There is one large

island. How many medium islands are in the design?

If you develop any interesting designs, the instructor would be interested in seeing the formulas and pictures.
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Observe that each of the following L-systems has a tilde (~) immediately after the opening brace. This tilde tells

Arcnel that an L-system is an arc L-system. In an arc L-system, ‘L’ tells the turtle to draw an arc of a circle while

turning to the left (i.e., counterclockwise), and ‘R’ tells the turtle to draw an arc of a circle while turning to the right

(i.e., clockwise). Start  Arcnel. Select  New L-system in the Edit menu. For each of the following four L-systems,

type the L-system in the L-system window and then process the text and then save the L-system.

Rapids {~

  Angle 5

  Axiom A

  A=RLA

}

Spiral4c {~

  Angle 4

  Axiom C16L

  L=L@.9<1L

}

Spirals8c {~

  Angle 8

  Axiom C16Y

  X=@.93LX

  Y=+@.9[@.4LX]G<2Y

}

Spirals9c {~

  Angle 9

  Axiom C16KZ

  K=@.9LKR@I.9

  Z=<1@.9LKZ

}

1) Open the file to which you saved the above formulas. Choose Rapids and let the order be 4. Select Debug in

the Edit menu. What is the length of the command string? How many times does ‘L’ appear in the command

string?

2) Click Next once. What is the current angle measure for the turtle? Study the arc traced by the turtle. Did the

turtle turn clockwise or counterclockwise as it made the arc? By how many degrees did the turtle turn as it

made the arc? Hint: The initial angle of the turtle can be thought of as being 360°.

3) Click Auto. What is the final angle measure for the turtle?

4) Click Exit. Select Choose L-system in the File menu. Choose Spiral4c with an order of 5. Select Debug in the

Edit menu. What is the length of the command string?

5) Carefully watch the turtle. Click Next once. What happened to the turtle when Next was clicked?

6) Click Next again. Did the turtle turn clockwise or counterclockwise as it made the arc? By how many degrees

did the turtle turn?

7) Click Next until the third ‘L’ is selected in the Length window. When the turtle draws an arc, it uses its linear

crawl length for the radius of the circle that contains the arc it will draw. What is the current crawl length for

the turtle?

8) Click Auto. When the turtle is done crawling, write the displayed crawl length to 5 decimal places.

9) Click  Exit. Select  Choose L-system in the  File menu. Choose  Spirals8c with an order of 50. Press  W on

keyboard and change the width to 3. The design should show a spiral of spirals. If we start counting with the

biggest spiral at the bottom of the window and go counterclockwise, the 3rd spiral should be yellow and the 4th

spiral should be green. Which spiral is the next yellow spiral? Which spiral after that one is the next yellow

spiral?

10) Select Debug in the Edit menu. Click Next until the first ‘]’ is selected in the Length window. Write the current

crawl length rounded to 6 decimal places.

11) Click Next two more times. What is the current angle measure for the turtle?

12) Click  Exit.  Select  Choose L-system in the  File menu. Choose  Spirals9c with an order of 70. The design

should show a spiral of connected spirals. Select Debug in the Edit menu. What is the length of the command

string?

13) Click Next three times. What is the current angle measure for the turtle?

14) Look over the command string and find the first ‘<1’. Click Next once. Then press N on the keyboard until

that first ‘<1’ is selected. What is the current angle measure for the turtle?
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Arc L-systems have extra commands available that can be useful even when arcs don’t need to be drawn. The extra

commands ‘&’, ‘:’, ‘`’, ‘%’, ‘*’, and ‘$’ are in the arc L-systems below. Don’t confuse ‘`’ (grave character) with an

apostrophe or single quote mark. Start Arcnel. Change the order to 4. Select New L-system. Type each L-system

below in the L-system window, process the text, and save the L-system (Leaf130b should draw only a vertical line).

Leaf129c {~

  Angle 8

  Axiom ++A

  F=@1.36F@I1.36

  A=F[+:2&A][-:2&A]FA

}

Leaf130b {~

  Angle 8

  Axiom ++A

  F=@1.18F@I1.18

  A=F[+:4&A]F!A

}

CircleGrid {~

  Angle 4

  Axiom $XA$B

  A=:`GXA ;don't confuse ` and '

  X=[@.2G+LLLL]

  B=:%+G+X!G:%*1B

}

1) Open the file to which you saved the above formulas. Choose Leaf129c and let the order be 21. This draws a

leaf shown on p. 129 of the book The Algorithmic Beauty of Plants (written by Przemyslaw Prusinkiewicz and

Aristid Lindenmayer). The substitution rule ‘F=@1.36F@I1.36’ makes use of a concept used in the Leaf1 and

Leaf2 L-systems in the “Fractint.L” file. Select Show Command String Text in the Edit menu. According to the

window that pops up, what is the length of the command string?

2) Click No. In arc L-systems, the ‘&’ tells Arcnel to ignore the next character as Arcnel applies substitution rules.

So the substitution rule ‘A=F[+:2&A][-:2&A]FA’ is not used on an ‘A’ that follows an ‘&’ in the command

string. For order 1 of Leaf129c, the command string contains ‘:2’. As Arcnel applies substitution rules to that

command string to make the command string for order 2, it replaces ‘:2’ with ‘:1’ (the number after the colon

is decreased by 1). When Arcnel applies substitution rules to make order 3, it replaces ‘:1’ with ‘:’ (which is

equivalent to ‘:0’). When making order 4, Arcnel deletes ‘:’ and the symbol after it (which will be ‘&’ in this

command string). Since the ‘&’ before ‘A’ is now deleted,  Arcnel no longer ignores ‘A’ and  Arcnel applies

‘A=F[+:2&A][-:2&A]FA’ to ‘A’.  Change the order to 1. Select  Show Command String Text. What is the total

number of colons in the command string? Change the order to 2. Select Show Command String Text. What is

the total number of colons in the command string? Change the order to 3. Select Show Command String Text.

What is the total number of colons in the command string?

3) Change the order to 4. Select Debug in the Edit menu. Click Auto in the Debug window. As the turtle crawls,

observe  that  no  colons  or  ampersands  are  ever  selected  in  the  Length window since  the  turtle  does  not

understand those symbols. How many colons are in the command string?

4) Click Exit. Select Choose L-system in the File menu. Choose Leaf130b with an order of 34. This draws a leaf

shown on p. 130 of The Algorithmic Beauty of Plants. The algorithm in Leaf130b is shorter than the algorithm

in the book since  Leaf130b makes use of ‘!’ which is not used in the algorithm in the book.  Select  Show

Command String Text. What is the length of the command string?

5) Click No. Change the order to 6. Select Debug in the Edit menu. Click Auto in the Debug window. How many

colons are in the command string?

6) Click  Exit. Select  Choose L-system in the  File menu. Choose  CircleGrid with an order of 5. Press  W and

change the width to 5 and click OK. How many circles are drawn?

7) The turtle ignores a symbol immediately after a ‘`’ (grave character). When the turtle sees ‘%’, it ignores all

symbols up to the next ‘%’. Then it looks at symbols again. If it comes to another ‘%’, it ignores all symbols up

to the next ‘%’. Then it looks at symbols again, etc. As Arcnel applies substitution rules, it replaces ‘*1’ with all

the characters that were between the first pair of ‘$’ symbols in the command string before the current round of

substitution. Change the order to 1. Select  Debug in the  Edit menu. Click  Next until ‘]’ is selected in the

Length window. Write the first three characters that immediately follow ‘]’.

8) Click Next twice. Change the order to 2. Select Debug in the Edit menu. Click Next until the first ‘]’ is selected

in the Length window. Write the character that immediately follows ‘]’.

9) Click Auto. Once the turtle is done crawling, click Exit. Change the order to 3. How many circles are drawn?
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Suppose a special plant grows as shown to the right. This plant

has alternating sections. Call the bottom section an X section

and the one above it a  Y section. Then the next one is an  X

section. The next one is a Y section, etc. As a new section is

added, it bends slightly to the left. At the top of an X section, a

small stem grows to the left of the main stem. At the top of a

Y section, a small stem grows to the right. Call  W the point

where  a  small  stem attaches  to  the  main  stem.  Call  A the

straight pieces of the small stems. At each stage of growth, the

existing stems lengthen by a factor of 1.1. Start  Arcnel. Select  New L-system in the  Edit

menu. Type the  SpiralPlant1 L-system in the  L-system window. Process the text and

save the L-system. Arcnel should display 4 line segments (3 of which are in the main stem).

The axiom ‘++++++++++X’ turns the turtle so it crawls up instead of to the right. The axiom

also places an X section at the base of the plant. The ‘F’ in the substitution rule ‘X=F+[W]Y’

draws the portion of the main stem in an X section. The ‘+’ tells the turtle to turn 9° to the

left. The ‘[W]’ puts a W attachment point at the top of an X section. Since ‘W’ is in brackets,

the small stem attached at a W point does not affect the rest of the plant. The ‘Y’ places a Y

section as the next section in the main stem. Once the substitution rule ‘W=++++@0.3A’ has

been applied, the ‘++++’ tells the turtle to turn 36° before it draws a small stem. The ‘@0.3’

decreases the crawl length so a small stem will be a lot shorter than the main stem. The ‘A’

causes a small piece of a small stem to be placed where the small stem attaches to the main

stem. The substitution rule ‘A=F+A’ causes the turtle to draw a small  A piece of a small

stem and then to turn 9°. The ‘A’ at the end of the substitution rule places another small A

piece after the piece that was just drawn. The substitution rule ‘F=@1.1F@I1.1’ multiplies

by 1.1 the  lengths  of  existing  pieces.  Future  pieces  aren’t  changed.  The ‘[!W]’  in  the

substitution rule ‘Y=F+[!W]X’ places a W attachment point at the top of a Y section. Since

this W attachment point is preceded by a ‘!’, the turtle will turn the opposite directions it

turns when drawing a small stem at the top of an X section.

1) Change the order to 4. Two small stems should be attached to the main stem. Select Debug in the Edit menu.

The title bar of the Length window should show a length of 126 (If not, click Exit and fix the L-system. Process the text

and save the L-system. Then select  Debug again). Click Auto in the Debug window. What is the total number of line

segments drawn by the turtle?

2) Click Exit. Change the order to 5. How many small stems are attached to the main stem?

3) Change the order to 40. The design should look like the design shown above. To attach smaller stems to the

small stems, edit the text in the L-system window so it is changed to the SpiralPlant2 L-system shown above.

Process the text and save the L-system. This changes the small stems so they consist of alternating A and B

sections. At the end of each of these sections is a V attachment point for a smaller stem made of U sections.

Select Show Command String Text in the Edit menu. What is the length of the command string?

4) Click No. Change the order to 7. Select Debug in the Edit menu. Click Delay in the Debug window and change

the number to 100. Click OK. Click Auto. When the turtle is done crawling, what is its angle?

5) Click Exit. Edit the text in the L-system window so it is changed to the SpiralPlant3c arc L-system shown

above. Observe that each ‘F+’ in SpiralPlant2 is replaced with the arc ‘L’ command. Also, the base of the

plant will not be vertical because of the changed axiom. Process the text. Save the L-system. Select Debug in

the Edit menu. The length should be 671. Click Auto. When the turtle is done crawling, what is its angle?

6) Click Exit. Change the order to 40. Select Show Command String Text in the Edit menu. What is the length of

the command string?

7) Click No. Change the order to 50. Select Show Command String Text. What is the length?

8) Click No. Select Fern60 in the Extra menu. Press L. Find ‘/’ in the L-system. Press . Find in the “More

Angles” section where ‘/’ is mentioned. What does ‘/45’ tell the turtle to do when ‘/’ has its normal meaning?

SpiralPlant2 {

Angle 40

Axiom ++++++++++X

  F=@1.1F@I1.1

  X=F+[W]Y

  Y=F+[!W]X

  W=++++@0.3A

  A=F+[V]B

  B=F+[!V]A

  V=++++@0.3U

  U=F+U

}

SpiralPlant3c {~

Angle 40

Axiom +++++++X

  L=@1.1L@I1.1

  X=<1L[W]Y

  Y=<1L[!W]X

  W=++++@0.3A

  A=L[V]B

  B=L[!V]A

  V=++++@0.3U

  U=LU

}

SpiralPlant1 {

Angle 40

Axiom ++++++++++X

  F=@1.1F@I1.1

  X=F+[W]Y

  Y=F+[!W]X

  W=++++@0.3A

  A=F+A

}
X

Y
X

Y



9) Select  SierpinskiCurveC in the  Extra menu. This draws a curve to approximate the Sierpinski triangle. Find

both ends of the curve. At which vertex of the main triangle is the center of the curve?

10) Open “Arcnel.AL” (If it doesn’t exist, select  Write Arcnel.AL in the  File menu. Click the  Save button. Then open “Arcnel.AL”).

Choose SrpnskiFace with an order of 1 (To find  SrpnskiFace, scroll nearly to the end of the ‘S’ section in the list of

names). Select  Debug in the Edit menu. Click Next many times while observing how many degrees the turtle

turns at each ‘+’. Click  Auto. When the turtle stops, at what vertex is it? What is its angle? How many ‘+’

commands would be needed to change its angle to 0° (the same direction as 360°)?

11) Click Exit. How many faces are drawn? Change the order to 2. How many faces are drawn? Change the order

to 3. How many faces are drawn?

12) Select Show L-system Text in the Edit menu. Edit the name to change it to SrpnskiFaceL. The axiom is quite

long. Make it even longer by adding ++C4FH to the end of it. Add these two substitution rules to the L-system:

H=+FK-FH-FK+ and  K=-FH+FK+FH-.  Process the text.  This  should draw an orange curve consisting of  line

segments where each segment is on a side of a small triangle that contains a face. Save the L-system. Change

the order to 1. Imagine the turtle starting at the left end of the orange curve and crawling up the first segment.

Would a triangle with a face be on the left or the right side of the turtle? As the turtle crawls across the next

orange segment, would a triangle with a face be on the turtle’s left or right side? As the turtle crawls down the

last orange segment, would a triangle with a face be on the left or the right side?

13) Change the order to 0. If the turtle starts at the left end of the orange segment and crawls the length of the

segment, on which side of the turtle is there a triangle with a face?

14) Change the order to 2. If the turtle starts at the left end of the orange curve and crawls the length of the first

orange segment, on which side of the turtle is there a triangle with a face? As it crawls the next segment, on

which side of the turtle is there a triangle with a face? As it crawls the next segment, on which side of the turtle

is there a triangle with a face?

15) Let FH be an orange segment where there is a face on the left side of the turtle. Let FK be

an orange segment where there is a face on the right side of the turtle. The diagrams to

the right label the line segments accordingly. When going from order 0 to order 1, FH is

replaced with +FK-FH-FK+ where ‘+’ means to rotate 60° counterclockwise and ‘-’ means

to  rotate  60°  clockwise.  When  going  from  order  1  to  order  2,  FK is  replaced  with

-FH+FK+FH-,  and  FH is again replaced with  +FK-FH-FK+.  This produces the sequence

+-FH+FK+FH--+FK-FH-FK+--FH+FK+FH-+.  These  substitutions  are  implemented  in

SrpnskiL which  is  shown below the  Order  2 diagram.  Edit  the  text  in  the  L-system

window so it is changed to the SrpnskiL L-system. Process the text. This should draw

the order 2 curve shown to the right. Save the L-system. Change the order to 3. How

many line segments are in the curve?

16) Change the order to 4. Select Debug in the Edit menu. Click Auto. As the turtle crawls,

observe that it does a lot of turning back and forth at certain vertices. Write the last 4

characters in the command string.

17) Click  Exit. Except for the beginning of a curve, each  FH segment is preceded by an  FK

segment, and each FK segment is preceded by an FH segment. Both ‘+’ and ‘-’ are added

at a vertex when going from one order to the next. These rotations undo each other. To

decrease the amount of turning, change the ‘H’ and ‘K’ rules to these:  H=FK-FH-FK and

K=FH+FK+FH. Change the name to  SrpnskiL2. Process the text and save the L-system.

The curve shouldn’t change. At odd orders it changes orientation. Change the order to 3.

Select Debug in the Edit menu. Click Auto. When the turtle is finished, what is its angle?

18) Click  Exit.  Delete  ‘C4’  from the axiom.  Change the ‘H’  rule  to  H=:1~<1~FK-FH-FK.  Change the name to

SrpnskiL2c. Process the text and save the L-system. Change the order to 7. Select Spectrum Map in the Color

menu. At which vertex of the main triangle is the center of the curve?

19) Select  Help in the  Extra menu.  Find in the “Arcs” section the paragraph that  talks about the ‘#’  and ‘~’

symbols. When one ‘~’ is followed by another, what does the first ‘~’ tell Arcnel to do?

Order 2

Order 1

Order 0

F
H

F
H

F
H

F
H

SrpnskiL {~

  Angle 6

  Axiom C4FH

  F=

  H=+FK-FH-FK+

  K=-FH+FK+FH-

}

F
H

F
K

F
K

F
K

F
K

F
K

F
K

F
H

F
H
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The Creator designed plants so they can respond to conditions in the environment. These

responses can result  in  many variations  in  plant  design.  From our perspective,  these

variations  may  appear  random.  We  can  approximately  mimic  these  variations  by

introducing randomness into L-systems. Start Arcnel. Change the width to 3. Select New

L-system in the Edit menu. Type the PlantD L-system in the L-system window (This arc

L-system doesn’t need an ‘Angle’ command since it doesn’t have ‘F’, ‘G’, ‘L’, ‘R’, ‘+’, ‘-’, or ‘|’ and

doesn’t make use of the angle number specified by an ‘Angle’ command). Process the text. Arcnel

should display a vertical stem with two branches. Save the L-system. Select  Debug in the  Edit menu. The text

‘?24’ should be selected in the Length window. The title bar of the Length window should show a length of 43 (If

not, click Exit and fix the L-system. Process the text and save the L-system. Then select Debug again). Point the mouse at the turtle

and wait a little bit. A window should appear. In that window, the bottom line of information shows the value of a

special number called a seed. The seed contains information about the state of a “random” number generator. The

“random” number  generator  produces  a  sequence of  numbers  with  the superficial  appearance  of  randomness.

However, a precise formula generates the numbers, so they are not truly random. They are pseudorandom. The

command ‘?24’ tells the turtle to set the state of the pseudorandom number generator. Click Next.

1) Point the mouse at the turtle. According to the window that appears, what is the value of the seed?

2) The text ‘\90’ should be selected in the Length window. This tells the turtle to turn 90° counterclockwise. The

“Mode” column in the Debug window should display ‘N F’. Click Next. What does the “Mode” column now

display?

3) The text  ‘D’  should  be  selected  in  the  Length window. This  tells  the  turtle  to  draw while  crawling.  The

commands ‘\’ and ‘/’ change the direction the turtle crawls when it  sees ‘D’.  The commands ‘+’ and ‘-’

change the direction the turtle crawls when it sees ‘F’. The first triangle in the Debug window should point to

the right. That is the direction the turtle would crawl if it saw an ‘F’. The second triangle should point up. That

is the direction for a ‘D’ command. Click  Next twice. The text ‘?’ should be selected in the Length window.

This tells the turtle to ask the pseudorandom number generator for a number that will be ignored. This changes

the state of the generator. Point the mouse at the turtle and observe that the seed has not changed. Click Next.

Point the mouse at the turtle. What is the seed?

4) The text ‘\25’ should be selected in the Length window. Watch the triangles in the Debug window. Click Next.

One triangle should change direction. It shows the angle of the turtle when it is in ‘D’ mode. Point the mouse at

that triangle. What is the angle of the turtle?

5) The text  ‘\?10’ should be selected in the  Length window. This tells  the turtle  to turn counterclockwise a

“random” angle from 0° up to (but not including) 10°. Click Next. To the nearest hundredth, what is the angle

of the turtle? What is the value of the seed?

6) Click Next. The text ‘@?.7’ should be selected in the Length window. This tells the turtle to pick a “random”

multiplier from 1 down to (but not including) 0.7. Click Next. The “Multiplier” column shows the multiplier

picked by the turtle. Click Next twice. The text ‘!’ should be selected. This will reverse the meanings of ‘\’ and

‘/’. Click Next. The “Mode” column should display ‘R D’, and ‘\25’ should be selected in the Length window.

Click Next. What is the angle of the turtle? What is the value of the seed?

7) The text ‘\?10’ should be selected in the Length window. Since ‘\’ and ‘/’ have reversed meanings, the turtle

will turn clockwise. Click Next. To two decimal places, what is the angle of the turtle?

8) Click Exit. Change the order to 12. The right and left sides of the plant have different structures. This is a result

of the ‘K’ substitution rule which is written on two lines as K=,3,1 and K=[?B]!B,A. The first line has a comma

after the ‘=’. This tells Arcnel that the ‘K’ substitution rule contains options. The two numbers tell Arcnel that

there are two options which are to be chosen in a probability ratio of 3:1. The second line lists the two options

separated by a comma. Around 75% of the time, Arcnel replaces ‘K’ with ‘[?B]!B’. Around 25% of the time,

Arcnel replaces ‘K’ with ‘A’. Change the first line of the L-system to PlantD3 {~3  and process the text. This

changes the structure of the plant. Save the L-system. The ‘3’ after the ‘~’ is the seed that  Arcnel uses to

initialize the pseudorandom number generator before Arcnel applies substitution rules. Select Debug. Find the

PlantD {~653

  Axiom ?24\90DK

  K=,3,1 ;2 choices

  K=[?B]!B,A

  B=\25\?10T

  A=\??20T

  T=@.8@?.7DK

}



command  ‘\??20’  in  the  Length window.  Click  Next until  the  first  ‘\??20’  is  selected.  To  the  nearest

hundredth, what is the angle of the turtle?

9) The command ‘\??20’ tells the turtle to “randomly” pick an angle from 0° up to (but not including) 20°. Then

the  turtle  “randomly”  decides  whether  to  turn  clockwise  or  counterclockwise.  Click  Next.  To  the  nearest

hundredth, what is the angle of the turtle?

10) Click Exit. Change the order to 30. Select Debug. According to the title bar of the Length window, what is the

length of the command string?

11) Click Exit. Change the axiom to ‘\90DK’. Since ‘?24’ will no longer be in the command string, the turtle will

not set the seed to 24. The turtle uses the initial seed which is an unpredictable number that comes from the

state of the computer processor. Process the text. The plant should change. Select Redraw L-system in the Edit

menu (or press R). The plant should change again. Change the first line of the L-system to PlantDS {~ and

process the text (click Yes in the dialog box that appears). Save the L-system. Since the initial seed used for

substitution rule choices is no longer specified,  Arcnel picks a seed based upon the state of the computer

processor. Press R. Do it again at least 3 more times. Select Process Shown Text (or press P). Do it at least 3

more times. When Redraw L-system is selected, the seed for substitution rule choices doesn’t change. It does

change when Process Shown Text is selected. Press R at least 5 times. Press P at least 5 times. Does pressing

R or P tend to change the plant the most?

12) If  
1 5

2
f += ,  then  (360°)(1  –  1

f )  = 137.507764...°  (the  golden  angle).

Change  the  order  to  4.  In  the  L-system window,  type  the  Florets

L-system. Process the text. Four circles should appear. Save the L-system.

Select Debug in the Edit menu. The title bar of the Length window should

show a length of 93 (If not, click Exit and fix the L-system. Process the text and save the L-system. Then select Debug again).

Click Next. A ‘[’ should be selected in the Length window. The next character should be ‘'’ (apostrophe or

single quote mark). As Arcnel processes the command string of an order to make the next order, the ‘'’ tells

Arcnel to ignore the next symbols until there is a number. The number is increased by 1. Look at the command

string in the Length window and see each number after each ‘Q’. Write those four numbers.

13) Click Next twice. ‘M’ should be selected. This tells the turtle to move without drawing. Click Next. ‘@I@’ should

be selected. This tells the turtle to multiply its crawl length by the inverse of the most recent multiplier. Since

the most recent multiplier is 1, the inverse will be 1, and the crawl length won’t change. Click  Next twice.

‘(360’ should be selected. This tells the turtle to draw a 360° arc while turning to the left. Thus a circle will be

drawn. Click Next until ‘@Q2’ is selected. Click Next. To four decimal places, what is the multiplier shown in

the Debug window? Click Next twice. To four decimal places, what is the multiplier?

14) Click  Exit.  Change  the  order  to  400.  Certain  flowers

have a design similar to what is shown. To mark spirals

in the design, type the FloretSpirals L-system in the

L-system window. Process the text. Two spirals should

be  marked  with  yellow  circles,  and  two  should  be

marked with orange circles.  Save the L-system. Study

the  orange  spirals.  They are  the  same  type  of  spiral.

Count  the  total  number  of  spirals  of  this  type.  There

should be 34. The yellow spirals are a different type of spiral. How many spirals of that type are in the design?

15) The golden angle is also called the Fibonacci angle. Select FloretsCR in the Extra menu. Do it again and again

and again (and more if desired). Press L. Find the lines B=,1,49 and B=<1, in the L-system window. These

lines form the ‘B’ substitution rule. The first line shows that there are two options. The second line shows one

option followed by a comma with nothing after it. This indicates that the second option is to delete ‘B’ from the

command string. According to the comments in the L-system window, how often is this done?

16) Press  . Find the word  stochastic in the “Randomness” section.  What is a stochastic L-system?  For more

stochastic experience, select StochasticDendriteC in the Extra menu and then select Seed Loop in the Edit menu and then click OK.

Florets {~ ;Don't confuse `

  Axiom K  ;with the ' below

  K=K\137.5['@Q1M@I@@.7(360]

}

FloretSpirals {~ ;order 400, 1114, or 1828

  Axiom [\PK]C5[B][\P:20&B]C4[V]/P:1&V

  P=137.507764

  K=K\P['@Q1M@I@@.7(360]

  B=:19&A ;137.507764*21-8*360=7.663044

  A=B\7.663044['@Q20M@I@@.7(360]

  V=:32&U ;137.507764*34-13*360=-4.736024

  U=V/4.736024['@Q8M@I@@.7(360]

}
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In arc L-systems, ‘"’ (double quote mark) tells the turtle to remember its location. If a

location has been remembered, then ‘"’ tells the turtle to draw a line segment from the

remembered location to the current location.  This location becomes the remembered

location.  Don’t confuse ‘"’ and ‘''’ (two apostrophes). Start  Arcnel and change the

width to 3. Select New L-system in the Edit menu. Type the Diagonals L-system in the

L-system window. Process the text.  Change the order to 5.  Arcnel should display a

pentagon with its diagonals. Save the L-system. Select  Debug in the  Edit menu. The

title bar of the Length window should show a length of 27. In that window, ‘"’ should

be  selected.  This  tells  the  turtle  to  remember  its  current  location.  Remember  that

location. Click Next until the next ‘"’ is selected. The remembered location should be

marked. A line segment should be drawn between the remembered location and the

current location which will now be the new remembered location. Point the mouse at

the  turtle  and  wait.  A  window  should  appear.  Its  second  line  shows  the  turtle’s

coordinates  in the  xy-plane.  The third line shows the turtle’s location in the  Arcnel

window. In this activity, the word coordinates refers to the coordinates in the xy-plane.

1) Write the turtle’s coordinates (the ordered pair shown after “(x, y)=”).

2) Click Next until the next ‘"’ is selected. Write the turtle’s coordinates.

3) Click  Exit.  Type  the  LeafCordate L-system in  the  L-system window.  This  L-system is  derived from an

algorithm on p. 123 of The Algorithmic Beauty of Plants. Process the text. Arcnel should display a tall and thin

octagon. Save the L-system. Change the order to 10. Select  Debug. The text ‘/90’ should be selected in the

Length window. This tells the turtle to turn clockwise 90°. Click Next. The first triangle in the Debug window

shows the direction the turtle would crawl for an ‘F’ or ‘G’ command. The second triangle shows the direction

for a ‘D’ or ‘M’ command. Point the mouse at each triangle and write each angle.

4) The text ‘=I’ should be selected. This tells the turtle to convert a ‘DM’ angle to an ‘FG’ angle. This command

does the inverse of the ‘=’ command which tells the turtle to convert an ‘FG’ angle to a ‘DM’ angle. An ‘=’ used

this way should not be confused with the ‘=’ that is the second character in a substitution rule. Click Next. Point

the mouse at each triangle and write each angle.

5) Click Next until ‘".’ is selected. This tells the turtle to store its memory of its current location at the top of the

stack. This way, that location will be remembered after a ‘]’ command. Then when the turtle comes to a ‘[’

command, that memory will be pushed back onto the stack. Remember the location of the turtle and then click

Next until the next ‘".’ is selected. The turtle looks at the top of the stack to see if a remembered location is

stored there. Since one has been, the turtle draws a line segment from that location to its current location. Write

the turtle’s coordinates.

6) Click Exit. Change the order to 18 to draw an outline of a cordate leaf. Select Toggle Axes in the Edit menu.

Then select Debug. Click Next until ‘".’ is selected. Write the turtle’s coordinates.

7) Click Exit. Change the name to LeafCordateSmooth. Change the angle from ‘40’ to ‘360’ and process the text.

Change the order to 154. Save the L-system. Find cordate in a dictionary and write its definition.

8) Change the order to 10. Type the SuspensionBridge L-system in the L-system window. Process the text. The

diagram resembles a suspension bridge. The curve along the top approximates the parabola y=( x

40
)2 . Save the

L-system. Select Toggle Axes. Then select Debug. The title bar of the Length window should show a length of

1,220. Click Next once. The command ‘"’ tells the turtle to remember its current location. Click Next once. The

command ‘[’ places a copy of that memory on the stack. Click Next twice. The command ‘[’ places another

copy of that memory on the stack. Click Next once. The command ‘@=1’ should be selected. This is an absolute

command because of the ‘=’. Normally, ‘@’ multiplies the crawl length by the value in the command. However,

‘@=1’ sets the crawl length to 1 instead of multiplying it by 1. While watching the crawl length in the Debug

window, click Next once. Then click Next until ‘".’ is selected. Write the turtle’s coordinates.

Diagonals {~

  Angle 5

  Axiom "A

  A=F+F+"A

}

LeafCordate {~

  Angle 40

  Axiom /90=I[A]![A]

  A=[X".]+A

  X=GX

}

SuspensionBridge {~

  Angle 4

  Axiom @40"[X]|!X

  X=XF[@=1+FYYYZ".]

  Y=FY

  Z=YYZ

}



9) Click Next until the next ‘".’ is selected. Write the turtle’s coordinates.

10) Click Next until the next ‘".’ is selected. Write the turtle’s coordinates.

11) Click Exit. Change the width to 5. In the L-system window, type the

FibonacciArcs L-system. Process the text. A spiral should appear.

Save the L-system. Change the order to 20. Select Debug. The title

bar of the Length window should show a length of 81. An ‘L’ should

be  selected.  According  to  the  Debug window,  what  is  the  crawl

length?

12) Click Next until the next ‘L’ is selected. What is the crawl length?

13) Click Next until the next ‘L’ is selected. What is the crawl length?

14) The text  ‘@=’  occurs  ten  times in  the command string.  After  each ‘@=’  is  a  number.  Write  each of  those

numbers in the order they occur.

15) Click Exit. Change the order to 1. Select Debug. Find ‘*1’ and ‘*2’ in the command string. As Arcnel applies

substitution rules to make order 2, Arcnel replaces ‘*1’ with what is between the 1st and 2nd dollar signs. Arcnel

replaces ‘*2’ with what is between the 3rd and 4th dollar signs. Write what is between the 1st and 2nd dollar signs.

Also, write what is between the 3rd and 4th dollar signs.

16) Click Exit. Change the order to 2. Select Debug. Find ‘''’ in the command string. If Arcnel sees a single ‘'’ in

a command string as substitution rules are applied, then  Arcnel searches for a number after the ‘'’. Once a

number is found, it is increased by 1. If Arcnel sees ‘''’ in a command string as substitution rules are applied,

then  Arcnel reads the number that  is  immediately after  the ‘''’  and remembers  that  number.  Arcnel then

searches for the next number in the command string and adds the remembered number to that number. Write

the number that is immediately after ‘''’. Also, write the next number in the command string.

17) Click Exit. Change the order to 17. Select Debug. Write what is between the 1st and 2nd dollar signs. Also, write

what is between the 3rd and 4th dollar signs.

18) Click Exit. Change the order to 18. Select Debug. Write the number that is immediately after ‘''’. Also, write

the next number in the command string. Then add those numbers and write the sum.

For better understanding of  FibonacciArcs, observe ‘''’ in a command string. Then observe that for the next

order, the first ‘'’ is deleted by the substitution rule ‘'=’. However, the second ‘'’ is not deleted. The reason is that

when Arcnel sees ‘'’, then Arcnel does not apply substitution rules from the character after that ‘'’ up through the

number that is changed by the command. Below are sequences from command strings from different L-systems.

For the command strings on the left, the L-system has the substitution rule ‘'=’. That substitution rule is not in the

L-system for the command strings on the right.

Delete ‘'’ with rule ‘'=’ Delete ‘'’ with command ‘:’

Order 0 ''3$4$ :''3$4$

Order 1 '3$7$ '4$4$

Order 2 4$7$ '5$4$

These activities have not introduced everything there is to know about the symbols that can be used in L-systems.

To develop a better understanding of the meanings of symbols, select Help in the Extra menu and read about the

symbols. Also, study L-systems in “Arcnel.AL” and L-systems in the Extra menu. To improve understanding, look

at the command strings for orders 1, 2, 3, etc. Even if there is nothing to draw for an order, the command string can

be displayed by selecting Show Command String Text in the Edit menu. Once a command string is displayed, it can

be selected by using a mouse and then copied by pressing +C. Then it can be pasted into an editor. It is

helpful to paste command strings from successive orders into an editor so that the results of substitution rules are

more easily seen.

The rule ‘'=’ doesn’t cause the first ‘'’ to 

be ignored. The first ‘'’ is deleted but not 

ignored. The command ‘:’ does cause the 

symbol immediately after it to be ignored.

FibonacciArcs {~

  Angle 4

  Axiom :2:1&~$1$&~L:4:3&~$1$&~K

  K=@=*2H:5:4&~B*1$*2$&~:1&K

  B='' ;Don't confuse '' and "

  H=L

  '=

}


